Unity 5 décapite la 4.6 : plus de support en janvier

Unity 4.6 a eu une belle vie, pleine de promesses tenues selon moi avec son nouveau GUI. Mais voilà les belles histoires ont une fin.

Unity 4.6 n’aura plus de patch ni de release dès janvier 2016.

C’est le message qui est arrivé dans mes mails ce matin…

Certains continue à utiliser 4.6 pour diverses raison (gros projets en cours) et même si c’est relativement aisé, passer de 4.6 à 5.0 ou à 5.2 peut être une tannée. Sur de gros projets utilisant de nombreux assets (eux aussi à mettre à jour) ça peut être chronophage ! Du coup sortir un projet sur une version plus supportée, sans migrer ou migrer avec risque d’effort important ? dure question…

Bon courage amis passionnés !

De mon côté j’ai déjà sauté le pas du 5 puis du 5.2 (amenant son lot de soucis concernant les plugins androids) 🙂

You may also like...

7 Responses

  1. Max dit :

    Ouaip, j’ai vu cela ce matin aussi.
    Ma foi, il fallait s’y attendre je pense.

  2. manthoR dit :

    Yep!
    Le support logiciel est de plus en plus court je trouve, mais n’étant pas sur d’énormes projets durs à migrer ca ne m’impacte personnellement pas.
    D’autant que 5 et ses rendertextures pour les indies j’ai carrément sauté dessus 😀

  3. Max dit :

    Oui, l’apport de la version 5 ne se dément pas, à tout point de vu (c’est pas moi qui dirait le contraire).
    Par contre, il est vrai que pour ceux qui doivent migrer, c’est un sacré taf dans certains cas.
    Pour ceux qui dev avec une v4.6, elle reste stable et pas non plus bugué jusqu’à la corde. Dans la majorité des cas, sur des projets très avancés, pas de raison de s’inquiéter, c’est pas parce qu’en janvier le support ne sera plus assuré, que toutes les 4.6 vont crasher en fevrier 😀

  4. manthoR dit :

    Oui c’est sur, mais le seul problème d’une version non supportée reste la compatilité dans le futur avec les os cibles et autres libs.
    Genre un truc qu’apple rendrait obligatoire pour pouvoir publier une app sur ios10.
    Et reste aussi à voir si les editeurs d’assets arrêteront également les maj sur 4.6 (exemple : google play services qui évoluent sans cesse… 🙁

  5. ZJP dit :

    J’ai encore la 3.5.7. Raison : elle compile des applis pour ARM V6. 😉

    C’est certain qu’un changement de version majeure dans le cas d’un projet avancé n’est pas une décision facile à prendre. Cela dit, ceux qui « ciblent » le desktop ont/auront moins de souci que ceux qui… »visent » les plateformes mobiles (forcement…c’est mobile…donc plus compliqué a…toucher 🙂 )

    Souhaitons qu’UT clôture la V4 avec la version la plus stable possible. La 4.6.9.9 (?) ^^

  6. Max dit :

    @manthoR Pour le coté pérenne , c’est sur que c’est pas top, tu as raison.

  7. manthoR dit :

    @zjp : effectivement, et la 4.6 pour les GPU à base de Tegra 2… En 5 ca build, ca crash pas, ca lance l’appli, un beau splash screen unity et « Your device is not supported by this application »
    Ah les joies du mobile 😀

Laisser un commentaire

Aller à la barre d’outils